1.6 on macOS Sierra gives Problem dialogue every launch

  • After updating to 1.6 on macOS Sierra, I get a Focused Problem Reporter box (image) on every launch. I've tried full uninstall and clean instal too, and still see this problem. I've reported the problem in the box and sent it in, but anyone else seeing this?
    Focused 1.6 problem box.tiff

  • I'm definitely seeing this too. In my case, clicking the i icon and going to Exception shows:

    Exception Type:  SIGTRAP
    Exception Codes: TRAP_TRACE at 0x10c10744e
    Application Specific Information:
    *** Terminating app due to uncaught exception 'NSInvalidArgumentException', reason: '-[NSNull integerValue]: unrecognized selector sent to instance 0x7fffe781af10'
    Last Exception Backtrace:
    0   com.apple.CoreFoundation            0x00007fffcd057513 __exceptionPreprocess + 147
    1   libobjc.A.dylib                     0x00007fffe172fcad objc_exception_throw + 48
    2   com.apple.CoreFoundation            0x00007fffcd0d8d34 -[NSObject(NSObject) doesNotRecognizeSelector:] + 132
    3   com.apple.CoreFoundation            0x00007fffccfc9bf5 ___forwarding___ + 1061
    4   com.apple.CoreFoundation            0x00007fffccfc9748 _CF_forwarding_prep_0 + 120
    5   com.71squared.focused               0x000000010bd75f01 0x10bd4a000 + 179969
    6   com.71squared.focused               0x000000010bd4d0a7 0x10bd4a000 + 12455
    7   com.apple.Foundation                0x00007fffce9ebdbd NSKeyValueNotifyObserver + 350
    8   com.apple.Foundation                0x00007fffce9eb654 NSKeyValueDidChange + 486
    9   com.apple.Foundation                0x00007fffceb2a2d7 -[NSObject(NSKeyValueObservingPrivate) _changeValueForKeys:count:maybeOldValuesDict:usingBlock:] + 944
    10  com.apple.Foundation                0x00007fffceb29c2a -[NSObject(NSKeyValueObservingPrivate) _notifyObserversOfChangeFromValuesForKeys:toValuesForKeys:] + 807
    11  com.apple.CoreFoundation            0x00007fffcd0af6ea forEachObserver + 298
    12  com.apple.CoreFoundation            0x00007fffcd0af908 -[CFPrefsSource _notifyObserversOfChangeFromValuesForKeys:toValuesForKeys:] + 72
    13  com.apple.CoreFoundation            0x00007fffcd0fe172 __84-[CFPrefsSearchListSource asynchronouslyNotifyOfChangesFromDictionary:toDictionary:]_block_invoke_2 + 34
    14  com.apple.CoreFoundation            0x00007fffccfed3ac __CFRUNLOOP_IS_CALLING_OUT_TO_A_BLOCK__ + 12
    15  com.apple.CoreFoundation            0x00007fffccfce424 __CFRunLoopDoBlocks + 356
    16  com.apple.CoreFoundation            0x00007fffccfcdba5 __CFRunLoopRun + 917
    17  com.apple.CoreFoundation            0x00007fffccfcd5b4 CFRunLoopRunSpecific + 420
    18  com.apple.HIToolbox                 0x00007fffcc56ef6c RunCurrentEventLoopInMode + 240
    19  com.apple.HIToolbox                 0x00007fffcc56eca9 ReceiveNextEventCommon + 184
    20  com.apple.HIToolbox                 0x00007fffcc56ebd6 _BlockUntilNextEventMatchingListInModeWithFilter + 71
    21  com.apple.AppKit                    0x00007fffcac655f5 _DPSNextEvent + 1093
    22  com.apple.AppKit                    0x00007fffcb3758eb -[NSApplication(NSEvent) _nextEventMatchingEventMask:untilDate:inMode:dequeue:] + 1637
    23  com.apple.AppKit                    0x00007fffcac59fbd -[NSApplication run] + 926
    24  com.apple.AppKit                    0x00007fffcac24a8a NSApplicationMain + 1237
    25  libdyld.dylib                       0x00007fffe200d255 start + 1

    Going into ~/Library/Containers/com.71squared.focused/Data/Library and cleaning out:

    • Preferences/com.71squared.focused.plist
    • Saved Application State
    • Caches

    ...did nothing.

    Even running defaults delete com.71squared.focused did nothing.

    I thought it had to do with relying on auto-save to have 20-ish untitled documents maintained, but now it's looking like even from a fresh start nothing helps.

    Among other things, this also seems to be messing up something so that Undo/Redo just don't work, they stay disabled and never enable, nor does the Undo item change to reflect what there would be to undo, making it look like the undo manager isn't hooked up at all. I went through a number of upgrades when Typed was Typed, and nothing like this happened before. Having this sort of thing happening to a productivity tool is very disconcerting.

  • 71squared, no comment on this? This is a show-stopping bug. The app is unusable on the currently shipping version of macOS.

  • administrators

    Sorry for the delay. We've been investigating this and have hopefully found the problem. We are hoping to get an update out in the next 48 hours.


  • Does that fix the Undo bug too?

  • Great to hear! I'll look forward to the fix.

  • administrators

    Hey guys,

    So there is good news and bad news. The good news is that I've been able to fix the crash on launch that some people have been experiencing.

    The bad news is that in rectifying the undo problem I've discovered a far, far worse problem with the underlying text view in macOS Sierra. A test app, crash report and video has been sent to Apple and we're waiting to hear back from them.

    Hopefully they'll come back with a simple fix.


  • Thanks for keeping us updated. A shame this wasn't uncovered with the GM seed.

    Any chance you might share your text view diagnosis on e.g. https://openradar.appspot.com/ ? That could get other developers to file duplicate bugs and help the bug be noticed and fixed.

  • administrators

    Sure, radar's as follows.

    NSTextView is unusable

    Observers of NSUserDefaults are notified multiple times

    ScopedBoo reaches maximum (255) open files

    The text view in Sierra wasn't actually busted until just before the GM came out. All our apps were working perfectly from the first beta, then something changed and messed it all up :confused:

    Test project for the text view:
    TextViewContainer Sent to Apple.zip

  • That's great. I hope they react eventually. I'm probably going to upgrade to the 10.12.1 beta just to see if anything is fixed in this regard.

  • administrators

    Heh, you brave old soul you!.. It'll be interesting to hear how you get on ;)


  • Still no dice on the just released third beta - all symptoms seem to be fully intact.

  • Just updated after months away and discovered this issue. I found the forum and was glad to know it was not my fault! Waiting with 'bated breath (not) for Apple to resolve this. A big disappointment, since I was trying to produce a newsletter with Markdown!

  • @tom What news re bug with Focused and MacOS Sierra not working?

  • administrators

    Hey guys,

    I've just launched Focused 2, a free upgrade for current users and it works on Sierra ;)

    The app has also been transferred to Codebots.co.uk, a company that I'm the founder of.

    71Squared has historically targeted developers and pro users with tools like Particle Designer and Glyph Designer. Last year 71Squared acquired Focused and Deep Dreamer from Realmac Software. We've loved taking on the responsibility of these apps, but at the same time it's distracted us from what 71Squared set out to achieve.

    The update should 'just work' with your current license, so go ahead and give it a try.


Log in to reply

Looks like your connection to Forum was lost, please wait while we try to reconnect.